Browser Requirements

Browser Requirements

As of 30JUL2018, the minimum supported internet browser requirements for connecting to ARCOS are:

  • Google Chrome 52.x (first released July 2016) – PREFERRED
  • Microsoft Internet Explorer 11 (first released October 2013)

Background:

In DIRC’s ongoing effort to improve the security of its ARCOS software platform and adhere to security best-practices, we will be removing ARCOS support for TLS 1.0 and 1.1 on 29JUL2018.

TLS is a set of rules that your web browser follows to establish a secure connection with the ARCOS Site Portal website.

You may have received similar notices from other companies you work with, as both TLS 1.0 and 1.1 are now considered insecure and the move to remove support for them is occurring industry-wide.